100% cpu

WD locked up again today with 100% cpu by wd.exe.

This is happening every 2 days or so for me. I have to power the PC down as it wont do anything when 100% CPU.

Version 10.29R but this has been happening for the last few weeks.



I have had similar problems, could have something to do with FTP. It seems to be running at 100% when I have the problem. I would be interested in the fix. Currently running on 10.29t.


I had another incident of 100% CPU lockup. This time it only ran for about 4 hours - version 10.29U. No errors in the programerrorlog file. Free memory at tile of the lockup was 200 mb


i am not sure whats wrong, as it does not seem to be a widespread problem , and I have not seen this happen myself


It has been happening to me for the last few weeks. I get about 2 days before 100% CPU. Task manager shows weatherd.exe is utilizing 100% CPU. Today I uploaded from 10.29S to 10.29U - it ran for four hours then locked up. When it happens I have to power off the PC.

I know its one of those flaky things that are hard to find. I appreciate any help you can give.



The machine I run WD is dedicated to WD. I rarely use it unless I need to take a screen capture. I have noticed that after a few days (6-8) if I try to open the main WD screen (normally minimized in tray) it will freeze. WD will stop collecting data from the station, and task manager will show a very high CPU percentage for WD. This machine has a large amount of RAM which may explain why it can go for 6-8 days before this happens. It could the same problem you have just takes longer to manifest itself here due to the amount of RAM in my machine. Aside from the length of time it takes this sounds like the same thing I see here.

before you open the screen dan, check the file, programerrorlog.txt, which might have access errors or similar in it

Brian, i will try and help you out.
Since turning off the databackup, WD been work greating, except for a crash yesterday, but i will let it go and see what happens.
I think its FTP related, because the uploads stops, but the graphs are still updated.

2.4 Ghz P4
1.5 Gb Ram

When mine locks up there are no errors in the errorlog file and I usually have around 200 meg of free RAM


i do know some people have trouble with the data zip back up in wd…(i dont)
but that only runs once a day, at the time set (hour)

Just installed version v (full) and emptied the programerrorlog.txt file. I will let’er go a few days and keep you posted on any errors. I can get to the file over the network so I don’t have to use the computer with WD running on it. I am fairly certain that in the past there have not been any errors in the log at the time of failure. I think WD locks up before it has a chance to write anything. The problem is I have to maximize WD before it actually fails…

My backups are completing just fine and don’t seem related to the 100% CPU issue.

I set a mapped network drive on another PC as the location of my backup and backups complete without errors. The lockups do not coincide with the time I have set for backups. For example today I installed 10.29U at 11 AM and I had a 100% CPU lockup 4 hours later at 3 PM. My backups happen at 8:55 pm.


I’ve had the same problem for awhile now. My CPU usage runs under 10% until the top of every minute then jumps to 100% for a few seconds while WD updates. While at 100% the clock on the WD screen does not move then jumps to the correct time when the CPU usage drops off 100%. I’ve seen the usage stay at 100% for over a minute then drop back to normal.

When it happens to me the 100% CPU condition lasts for hours until I power off the PC


Hi Rick,
I notice you are using 10.29L - there was a version or two that had a “minute freeze” where the observations you noticed were happening to a lot of people - Brian had a look and altered some code and fixed - I know 10.29r onwards is ok. So if you downloaded the latest version of WD then hopefully you will not see that 100% CPU and freeze any more.

yes, what you are reporting rick and what frank is reporting, are 2 different kettle of fish :wink:


I have WD running, full mode, on the new machine for about 36 hours now.

Dell Dimension 3000
P4 3 GHz with HT
512 MB RAM

I have not seen any CPU use over 50% from WD. I have tried to watch the usage for 10 - 15 mins several different times including top and bottom of the hour and still have not seen anything over 50%… as I said FWIW :wink:


I had another incident of 100% CPU 2 hours after installing 10.20Vrev. This time I was able to see in task manager that clientrawrealtimeftp.exe was the culprit. I used manager to end the task. The CPU util dropped to zero and immediately popped back to 99%. I could never end the task. I had to power off once again.

Considering the flaky graphs in WDLive which come from clientraw, and now this I wonder if issues are related.

Anyways 10.29Vrev locked up in 2 hours.


Thanks Brian


frank, you will have to wait until Julian wakes up to comment on your “flaky” graphs
but that has nothing to do with the clientrawrealtimeftp.exe problem you are expericing, which might be due to network/internet/web server problems
do you have the clientraw real time ftp set to restart instead of relogin?

Yes Restart instead of re-login and set for every 30 minutes